Website Requirements and Feedback

Browser Requirements

Pacific Coastal Airlines’ website is designed to work with most common Internet web browser software. Please be sure your Internet browser software is up to date as many older versions do not support the latest Internet technology and may make certain features of our website unavailable.

Important: Effective September 24, 2018 our booking engine will no longer support TLS 1.0 technology as it is being phased out. To determine if your web browser will support our booking engine after September 24, 2018 click here. If you are presented with a green screen that says “TLS 1.0 Deactivation Test Passed” your web browser will remain compatible with our booking engine.

Supported Internet Browsers

To download or upgrade your web browser, click the links above then follow instructions to install the software.

Internet Explorer

If you wish to use Internet Explorer to view our website, you are advised to upgrade to the most current version. Internet Explorer version 10 (and previous versions) do not support our website. To determine what version of Internet Explorer you are using, please visit the following website. Please note that Internet Explorer version 8 to 10 are only supported when running on Windows 7 or newer if TLS 1.0 is manually disabled. For this reason, we recommend updating to Internet Explorer version 11 or Edge.

To download or upgrade your Internet Explorer software, click the link above then follow instructions to install the software.

Preferred Settings

  • Screen Resolution: 1024 x 768 pixels, or higher
  • Javascript: Enabled
  • Cookies: Enabled

 Recommended Plugins

  • Adobe Acrobat Reader (to read PDF documents)
  • Adobe Flash Player (to see animations)

Website Feedback

Contact

 

Verification